Jump to content

Battery Or Pump?


Iwantacaravan
 Share

Recommended Posts

Hi can someone tell me if the water pump has to have the battery to work? I'm having problems and I'm not sure if it's the pump or the battery. I've a sneaking suspicion it might be that a new battery is needed. I take it the pump won't run from the ehu? Please enlighten this beginner!!

Link to comment
Share on other sites

The pump runs off the 12v system. ...

Lunar Solaris 1 Limited Edition 2007 Hopefully Behind A

BMW 520D MSport Touring. ...

 

***** Jack of all Trades. ... Master of None *****

Link to comment
Share on other sites

Yep, I seconded that your pump runs of the 12v system in your caravan. if you connect your battery and plug the caravan into the mains you should be able to work the pump if the pump doesn't work when you unplug the mains then it could be the battery, you would have to check it with a meter.

Link to comment
Share on other sites

Do any of your other 12v systems work? Lighting is a good check.

 

If the answer is no, then it's probably the battery or the battery charger.

 

If you have a multimeter you can check voltages on the battery and at the pump connections.

 

Regards,

Stephen

Olympus II 620-6 & Mitsubishi Shogun

Follow us on FacebookInstagram and Twitter

Link to comment
Share on other sites

 

Ok everything seems to work when hooked up but not pump. Also battery meter in van showing no life and no lights when hook up switched off, so I guess I need a new battery and that the pump needs battery connected and holding charge to work. Are batteries all much of a muchness? Or are some better than others please?

Link to comment
Share on other sites

There are two power outputs with batteries, so it depends on what appliances you have, whether you plan to use the caravan without EHU and if you have a motor mover. Yes to all of these = top whack battery required!

Link to comment
Share on other sites

Your battery might simply be dead. Your charger may have failed. See if you can get it charged off the van, preferably with a smart charger. Before spending out on a battery.

 

Even without a battery your vans 12 volt system should operate when on hook up.

 

 

If you do need a new battery and you intend to mainly use ehu. Get a small one. Despite what some people will try to tell you a car battery will be OK.

 

 

John

Volvo V70 D3 SE (was Peugeot 4007, SsangYong Korando), Pulling a Lunar Clubman SI 2015. If you are depressed, you are living in the past. If you are anxious, you are living in the future. If you are at peace, you are living in the present.

 

Link to comment
Share on other sites

No mover then only a small battery will do, or even a old car battery.

 

But I would expect the pump to work even with out a battery fitted while on EU.

 

Usually when the pump goes it take out the fuse supplying it, look in the 12 volt distribution panel for the fuse marked pump.

Link to comment
Share on other sites

Sounds like a fault with the pump or 12v supply if everything is working . Check that it is switched on or a fuse has blown . If it is a pressure switch system it might be stuck or if it has microswitches in the tap it might not be working or a loose wire somewhere.

 

I would suggest it is checked with a meter before buying a new battery as it could be other than the battery.

 

Dave

Edited by CommanderDave

Jeep Commander 3. 0 V6 CRD

Isuzu D- Max Utah Auto

Elddis Crusader Storm 2000 Kgs, Unipart Royal Atlas Mover .

 

Link to comment
Share on other sites

I don't know the model you have but check the obvious first, if there is no 12v supply it could simply be switched off. Some caravans have an isolator switch usually around the fuse box, its worth a check.

Link to comment
Share on other sites

Oww so I could need a battery and pump in that case then!

I will try charging battery off the van. The bloke I bought it from said you have to wiggle the pump sometimes to get it going?! I did have it working a few days ago, but today it won't work, more wiggling perhaps? Not sure if that means there's a problem with the actual pump, or where it plugs into the van?

Hi Digger, yes I know the switch and have put it on!

Link to comment
Share on other sites

Hmm just looked in the owners handbook under fault finding and under "pump doesn't run" one of the causes is "battery disconnected".

Link to comment
Share on other sites

I've had this problem with mine, the electric contacts that fit in to the van were corroded and had to wiggle it sometimes to get it pumping, I rubbed them over with a bit of emery cloth and in the female end just rolled up the emery cloth and twirled it inside, that seemed to fix the problem.

Compass Corona (Magnum) 524 (2003) -----------VW Passat Alltrack 170 BHP DSG

Link to comment
Share on other sites

A pump can be checked by applying 12 volts to the connector tags. If it does run test the connections on the van.

Simple jump leads will do it. Just take care not to short the leads in the process. :o

 

A few seconds only out of water.

Ford C-Max and Coachman Festival 380/2 SE 2006    Motto  Carpe Diem

Still trying to find the perfect pitch. ..110 amp Battery+ 65 watt roof mounted Solar and 25 watt Wind Turbine. LED lighting. Status Aerial 315. Loose chattels marked with UV,. Safefill Gas Fitted.

 

Link to comment
Share on other sites

I sometimes have to tap my pump into the bottom of the aquaroll before it works, it'll then work fine until the next time its put into storage

Paul B

. .......Mondeo Estate & Elddis Avanté 505 (Tobago)

Link to comment
Share on other sites

Hi Digger, yes I know the switch and have put it on!

Okay as long as you know where it is and as you say it is switch on that covers that problem.

Edited by Digger_07
Link to comment
Share on other sites

Update! I wiggled the pump and got it working again. Then the water would only run from kitchen tap when bathroom tap was on. ., ok microswitch fun! I eventually managed to locate switch under tap lever but couldn't test it by putting wires together as it seems to be a sealed unit! Anyway thought I would put tap back together before hunting down the correct switch, and to my amazement it started working again, and has been ever since!

The battery doesn't appear to hold charge, so I guess a new one is in order!

 

The latest issue is no hot air from vent in bathroom, but loads everywhere else. Tried closing all other vents to no avail. I understand I may be able to adjust a valve to divert more hot air to bathroom? I think heater is a Traumatic 3002. Any ideas? How do I access this valve? Do I need to remove front of heater and how do I do this please?

Link to comment
Share on other sites

Update! I wiggled the pump and got it working again. Then the water would only run from kitchen tap when bathroom tap was on. ., ok microswitch fun! I eventually managed to locate switch under tap lever but couldn't test it by putting wires together as it seems to be a sealed unit! Anyway thought I would put tap back together before hunting down the correct switch, and to my amazement it started working again, and has been ever since!

The battery doesn't appear to hold charge, so I guess a new one is in order!

The latest issue is no hot air from vent in bathroom, but loads everywhere else. Tried closing all other vents to no avail. I understand I may be able to adjust a valve to divert more hot air to bathroom? I think heater is a Traumatic 3002. Any ideas? How do I access this valve? Do I need to remove front of heater and how do I do this please?

On the back of the heater blower, just below the motor (6" or so) there is a variable black two way air valve, the has a variable lever on it to allow you to divert a higher percentage of air to the different main outlets.

An eye for an eye only ends up making the whole world blind.

Mahatma Gandhi

Link to comment
Share on other sites

Hi Dreadly

How do I access the fan? Do I have to take front off fire? If so how does the front come off, sorry but I'm new to caravanning! Many thanks

Link to comment
Share on other sites

Hi Dreadly

How do I access the fan? Do I have to take front off fire? If so how does the front come off, sorry but I'm new to caravanning! Many thanks

First make sure non of the air ducting has come detached at a joint. This has happened to me.

Alan

 

2005 Nissan X-trail 4WD diesel and Swift Charisma 540 2012 Lunar Clubman ES  2018 Lunar Clubman ES

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...