Jump to content

Carver Water Heater Trouble


oldyellar
 Share

Recommended Posts

Hi,

I m new to the forum and the new enough to the caravan scene.

We ve an Elddis vogue centime. V happy with it but cant get the hot water working yet. Theres water in the cold taps and when i turn on the hot water the pump runs but no water flows. We took out the filter outside and the water pumped out of it. The heater is warm to the touch and the fuses are ok. Your thoughts are welcome!

Link to comment
Share on other sites

Welcome to the forum! Have you let the taps run long enough to remove any airlocks?

2011 Land Rover Freelander 2, Lago grey 2013 Freelander Dynamic Black, followed by a 2013 Elddis 574 Magnum GT white

Link to comment
Share on other sites

There may be air in the water heater. Before turning on the water heater either gas or electric make sure that all the air has been bled from the pipework by opening the hot tap furthest from the pump until it stops spluttering and water runs freely. Close that tap and open the next nearest in turn until you reach the nearest tap to the pump by which time the water should run freely. I should just add that you should make sure that the drain down valve or stopper is shut or replaced. before filling the water system.

Link to comment
Share on other sites

Thanks to ye both. No water flows in taps after say 2/3 mins of running. Wheres the drain down valve?

Link to comment
Share on other sites

Depending on the age of the Carver you may find a plastic bung on the outside wall of the caravan close to where the Carver heater is installed. On my previous caravan the pump was operated by micro switches in the taps. If you have water flow when the you turn on the cold tap the micro switch on the hot may be faulty.

 

If the pump on your caravan is operated by a drop in pressure on opening a monobloc type single tap you may find the drain down valve inside the caravan adjacent to the heater is open. It is normally a yellow coloured lever operated valve which is open in the vertical position and closed when at right angles to the vertical.

Link to comment
Share on other sites

Sounds like the micro switch works because you can hear the pump coming on, if it was me I'd be thinking maybe a blocked hose?

Link to comment
Share on other sites

Is the pump definitely running when the hot taps are turned on?

Paul B

. .......Mondeo Estate & Elddis Avanté 505 (Tobago)

Link to comment
Share on other sites

Yes the pump runs when the taps are turned into an on position. How would i unblock the hose?

Link to comment
Share on other sites

The most likely cause is a damaged water inlet non return valve.

Unless you know how to change the inlet it would be better to get a mobile engineer to do it as using the wrong items can result in a whole lot more problems.

Link to comment
Share on other sites

Cheers. I ll have a look at it so. My bro is handy enough so i m sure we can have a go. . famous last words!

Link to comment
Share on other sites

 Share

×
×
  • Create New...