Jump to content

Help With Generator


Recommended Posts

Hello all, We are going away in the caravan this Saturday so i decided i would pull the Generator out to make sure all was well, all was not.

The thing starts up fine, no issue there. The issue lies on the fact that about 2 mins after starting it up the red "overload" light illuminates (this is without anything plugged into the generator) and when an appliance is plugged in (in this case a lamp) there is no power output.

 

The Generator is a KIAM KM2000i, only has 8 hours on it. I'm unable to find any kind of breaker for the ac side of it either.

 

I can also almost guarantee we haven't overloaded the generator on the last use, as we haven't powered anything near 2kw with it .

 

Alex.

Link to comment
Share on other sites

Oil Level ?

 

 

 

Dave

Jeep Commander 3. 0 V6 CRD

Isuzu D- Max Utah Auto

Elddis Crusader Storm 2000 Kgs, Unipart Royal Atlas Mover .

 

Link to comment
Share on other sites

Checked oil, Its full to the top.

 

Alex.

Link to comment
Share on other sites

Is it sitting on a level surface?

 

Prior to the overload warning illuminating does it give an output?

Link to comment
Share on other sites

Is it sitting on a level surface?

 

Prior to the overload warning illuminating does it give an output?

It is sitting on a level surface yes.

 

No, the light just stays illuminated, no output given at all.

 

Thanks

 

Alex.

Link to comment
Share on other sites

Hi Alex. In the OP you said the light comes on after 2 minutes. Are you now saying it's on all the time?

Link to comment
Share on other sites

Hi Alex. In the OP you said the light comes on after 2 minutes. Are you now saying it's on all the time?

The light does come on after about 2 minutes and then does not turn off, No power before or after it illuminates. Sorry for the confusion.

 

Alex.

Link to comment
Share on other sites

Can't help with your problem I'm afraid, but why don't you give either your supplier or the UK distributor a call?

Link to comment
Share on other sites

I would say that the inverter has failed. As Hairy suggests I think you need to take it to a dealer.

 

Sorry to be no more help.

 

Tony

Link to comment
Share on other sites

Can't help with your problem I'm afraid, but why don't you give either your supplier or the UK distributor a call?

 

 

I would say that the inverter has failed. As Hairy suggests I think you need to take it to a dealer.

 

Sorry to be no more help.

 

Tony

Looks like that is what i'm left with, Checked manufactures website, £178. 00 for a new inverter board and that wont make it to me in time. Looks like i'm relying on the solar panel this holiday with no microwave / hairdryer.

 

Cheers for all the advice & help :)

 

Alex.

Link to comment
Share on other sites

 

 

Looks like that is what i'm left with, Checked manufactures website, £178. 00 for a new inverter board and that wont make it to me in time. Looks like i'm relying on the solar panel this holiday with no microwave / hairdryer.

 

Cheers for all the advice & help :)

 

Alex.

Give Richard a call at REB 07877 679281. www. smallplantrepairs. co. uk/ He specialises in small generators, has a nation wide mobile servicing unit and willingly gives helpful advice over the phone.

Edited by Superpete

Pete
Range Rover(s) towing Buccaneer Caravel

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...