Jump to content

12 Volt Electrics Problems Corniche.


Gardener
 Share

Recommended Posts

I have a 1991 Swift Corniche, during a recent holiday I experienced the following. With the 240 volt mains connected and the KT12 charger unit switched on, everything worked. Later I switched off the battery charger, when I switched on a light it lit and immediately went out, the battery indicator went to the top of the red scale. When the charging unit was switched back on everything again worked. If I connected the van to the car using the auxiliary socket all 12V systems work.

Has anyone experienced this or have any idea of the problem.

 

Gardener

Link to comment
Share on other sites

Seems like your caravan battery is dead or not getting charged. However the fact that the lights work when the charger is on shows it is probably working. Connecting to the car with the auxiliary 12S socket results in running from the car battery.

Brian

Link to comment
Share on other sites

Would agree. Battery needs replacing.

Sadly no van anymore but 35 years was a good run

John

Link to comment
Share on other sites

Hi Guys, Thanks for the interest, the battery is fully charged, about 12. 7V, the failure only occurs when using the caravan battery through the usual system. As an experiment I connected the caravan battery direct to the Aux socket, as though connected to the car, and everything worked !!No mains connected.

 

Gardener

Link to comment
Share on other sites

 Share

×
×
  • Create New...