Jump to content

Problem With Water System.


taffyjenks
 Share

Recommended Posts

Hi I have a Coachman Amara 530/4 Caravan and on the last couple of occasions I have been out I have developed a problem. I attach the pump open the hot tap as instructed and switch the pump on. After a bit of coughing and spluttering the water runs freely and all hunky dory. However the next time I come to use the water,exactly the same coughing and spluttering before running freely.

 

The problem keeps recurring and after set up of the system for the first time the water will not heat until I have bled and filled it again. Any ideas?

Thanks

Tony.

Link to comment
Share on other sites

Your symptoms sound similar to ones I had recently. It ended up being a very small split in the inlet moulding - had to replace entire unit - not under warranty apparently (seems that most items don't come under the Coachman 5 year warranty!).

The split was allowing air into the system and also allowing water to leak out so check under the bed box to ensure it is not wet.

 

Alternatively and hopefully so, it is possibly a faulty non return valve in the pressure switch allowing the water to drain back down into the barrel.

 

Good luck.

Discovery D3 HSE + Coachman VIP 575/4 2016

www.pennplanning.co.uk

Link to comment
Share on other sites

Thanks for your reply will look into it. Funnily enough(or not),the area under the bed was wet the other week.

Thanks

Tony

Link to comment
Share on other sites

HI there I had a similar problem with my compass ralley. Coughing & spluttering from the vanity tap in the bathroom. I replaced the micro switch in the tap and its been ok since

Link to comment
Share on other sites

 Share

×
×
  • Create New...