Jump to content

Lunar Lexon Truma Immersion Element


Recommended Posts

Hi to all,I have a Lunar Lexon 640,up to 2 weekends ago the water heater was working fine,then all of a sudden it stopped working,water went cold,red led went out on switch,thought fuse had gone,(was told that there is a fuse!!)Went down to van again,fiddled with switch,the led came back on and the unit started working again. Until the next morning when it had blown the trip. Every time now when I press the switch on it blows the trip. Suspected faulty element(450 watt.)Went to caravan dealers and bought new element.(not cheap),went down to fit it this last week-end,but for the life of me I cannot see where it needs to go in on the unit. Can anybody advise me,does the seat unit have to come out? Because the water tank is half hidden underneath and cannot lift the top cover of the unit.

Link to post
Share on other sites

I suggest you get a mobile engineer to come and fix it, it is a pretty quick job to do, IF you know what you are doing .

The seat does NOT have to come off and the cover of the boiler does NOT need to be removed.

Link to post
Share on other sites

Thanks Brecon,for your response,nice dogs,mine is a Shi-Tsu

I got in touch with workshop at Michael Jordan Caravans,(where I purchased) and Paul said follow the wire to the boiler and I would find a flap on cover,will have another look whilst we are down there this week-end !!!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...