Jump to content

Powrtouch Motor Mover Only Working One Side


PBarton
 Share

Recommended Posts

Have you removed the red key and put it back in? Often works for me, otherwise may be a loose connection at the blue control box under the seats.

Link to comment
Share on other sites

Have you checked the cable connection to the mover controller . . I had an intermittent doing that and the nut on the terminal post was somewhat loose.

Roughing it . . but in comfort . .

Link to comment
Share on other sites

I had the same thing. I looked and the wire was attached to the mover fine. Later I realised there must bu 2 wires so went under the van and checked the wire that goes into the back of the motor. The rubber boot had split and the wire had come off: it just pushes back on with a spade terminal. That fixed it. Told Powertouch about the boot (it was 3 years old) they sent me a new one with no argument. Class.

Isuzu D Max pulling Bailey Unicorn 2 Valencia

Bailey Autograph 740 MH: Isuzu for sale LOL

Link to comment
Share on other sites

Mine did this last year. Same as Henrypartridge, bad spade connection on one of the motors.

BMW X6 M50D + Buccaneer Schooner 2017

Link to comment
Share on other sites

Most probably the spade connector. before you go under to check take a piece of emery paper to give them a light scuff. These also contain bushes that can be removed externally on the model i had, if the boot is burst the it could be moisture ingress to the bushes, i just remove both motors and stripped and cleaned them, no further issues. Call Powrtouch, they were very good at dispatching spares and reasonably priced.

Link to comment
Share on other sites

The roll pins went on mine, when coupled to the tyres the motor spins but not the rollers.

 

its about 11 years old so no warranty, but its not a long job ;)

Paul B

. .......Mondeo Estate & Elddis Avanté 505 (Tobago)

Link to comment
Share on other sites

Hi, went to use Powrtouch mover on Friday. Remote control seems to be sending signal and leisure battery ok but motor only working on one side of caravan. Any ideas?

If your mover is less than 5 years old Power Touch will probably come and repair it free of charge.

Regarding the side that is not working,if you press the control button for that side, can you hear a relay operating in the control box in the caravan. If you can the problem is probably with either corroded spade terminals on the motor or the brushes in the motor (as mentioned above). The best solution is to clean them up. If the problem is the brushes in an emergency you can press and hold the handset button while you give the motor a light tap on the end with a hammer,this usually works for the short term.

Link to comment
Share on other sites

I had the same thing. I looked and the wire was attached to the mover fine. Later I realised there must bu 2 wires so went under the van and checked the wire that goes into the back of the motor. The rubber boot had split and the wire had come off: it just pushes back on with a spade terminal. That fixed it. Told Powertouch about the boot (it was 3 years old) they sent me a new one with no argument. Class.

 

Hi, Thanks all for the sound advice!

 

Looked under caravan and the rubber boot had split and the wire had come off. Pushed back in and now working. Just need to contact Powrtouch and get a new rubber boot!

Link to comment
Share on other sites

Well done!

Maybe Powrtouch and other mover manufacturers could reduce their selling prices by only giving a one year warranty and a wee note to their customers to come here for support? ;):)

Link to comment
Share on other sites

 Share

×
×
  • Create New...