Jump to content

Caravan Toilet Help!


LEWINS1998
 Share

Recommended Posts

Hi, I own a compass omega 400/2. since I've got it the toilet has never flushed, I'm going to get a replacement fuse this weekend and have checked the pump and the propeller is turning correctly as it should, when I first got the caravan the lights dimmed when I tried to flush it but now the lights do no dim and my battery is full charged, thanks

Link to comment
Share on other sites

The pump impeller can get sticky if left unused, the more so if the pink agent is used in the flush tank. The pump can usually be removed and the impeller given a turn with a bent paper clip. Worth a try.

Link to comment
Share on other sites

As JTQ suggests, normally cures it nine times out of ten. You will need to prise the cover

off. It is only held on with sealer

2011 Land Rover Freelander 2, Lago grey 2013 Freelander Dynamic Black, followed by a 2013 Elddis 574 Magnum GT white

Link to comment
Share on other sites

Hi, I own a compass omega 400/2. since I've got it the toilet has never flushed, I'm going to get a replacement fuse this weekend and have checked the pump and the propeller is turning correctly as it should, when I first got the caravan the lights dimmed when I tried to flush it but now the lights do no dim and my battery is full charged, thanks

To me it would seem that the fuse has probably blown due to a sticky impeller as you say the lights used to dip but no longer do, I would do as others have sugested and that is clean the impeller and check that it rotates freely before replacing the fuse.

Link to comment
Share on other sites

To me it would seem that the fuse has probably blown due to a sticky impeller as you say the lights used to dip but no longer do, I would do as others have sugested and that is clean the impeller and check that it rotates freely before replacing the fuse.

Hi, thanks for the fast replies, I went and got the fuse today, I've tried to put it in and it just won't stay it keeps falling out?

Link to comment
Share on other sites

Hi, thanks for the fast replies, I went and got the fuse today, I've tried to put it in and it just won't stay it keeps falling out?

Not sure which toilet you have so whether it is a blade fuse or a 20mm glass one, but in either case if the fuse will not stay in, either it is not being inserted correctly or the fuse holder is in need of replacement

Link to comment
Share on other sites

Not sure which toilet you have so whether it is a blade fuse or a 20mm glass one, but in either case if the fuse will not stay in, either it is not being inserted correctly or the fuse holder is in need of replacement

Hi,it does have a blade fuse port that does not stay but also has a cylinder port and that is there and is broken so I'm replacing that tomorrow

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...