Jump to content

Trumastore Rapid Water Heater Problem On Gas


Recommended Posts

Hi All,

 

My van is fitted with a Trumastore Rapid with model numbers BN10 & BN103 (pre-2006 model). In the time I've had the van (around 5 years) I've had intermittent problems with starting the water heater when running on gas but always managed to get it started and keep it running, not so this time.

 

The heater will start as soon as the dial is turned to the on position and I can hear, smell and feel the heat from the external burner flue, within about 10 seconds it sounds like the electric sparker clicking rapidly as though attempting to light the gas and after another 10 seconds the whole thing cuts-out and stops working with the red fault light showing.

 

My conclusions so far are that the gas supply is OK, the electric supply is OK, the tank fills with water OK and the burner fires up OK.

 

Could this be a fault with the PCB, part number is B096 c01. 98 Rev 4? Is a replacement PCB the next option?

 

The heater runs fine on 240v, but I need it to run on gas also.

 

Cheers, Tim.

Link to post
Share on other sites

Ours did this last year. ... everytime turned tap on you'd hear the boiler fire up then after about 10 seconds the red light would come on. ... Went through everything. .. Sorted problem by turning the boilers gas stop tap off for a few seconds then back on. .. Not had problem since. It was just after I had to change the gas bottle. ..

Lunar Solaris 1 Limited Edition Hopefully Behind A

BMW 520D MSport Touring. ...

 

***** Jack of all Trades. ... Master of None *****

Link to post
Share on other sites

Ours did this last year. ... everytime turned tap on you'd hear the boiler fire up then after about 10 seconds the red light would come on. ... Went through everything. .. Sorted problem by turning the boilers gas stop tap off for a few seconds then back on. .. Not had problem since. It was just after I had to change the gas bottle. ..

 

I found the thread below and have been testing for most of the afternoon, pulling fuses and running the water heater on a spare leisure battery, nothing has stopped the clicking igniter which is intermittent until it finally stops the heater from working, then I started testing JanandJay's suggestion and closed the gas tap to the heater soon after switching the heater on, as soon as the tap is closed and the gas supply stopped then the clicking is continuous until the tap is turned on. Using this method, so far, the clicking stops and the heater functions normally. So now i believe it's a gas pressure or gas pressure sensor problem that is resolved by turning the gas off and then on, how bizarre! More testing to do, but so far it is working, think I'll be chatting with Truma to see what they think it could be.

 

http://www. caravantalk. co. uk/community/topic/55613-coachman-amara-2003-ultrastore-gas-heating-issues-blown-air-cutting-out/page__hl__+ultrastore%20+rapid#entry572047

Link to post
Share on other sites
  • 7 years later...

Hello,

 

I have a component failure for this circuit if someone can help?

Mice ate the coil by the spark transformer. 

 

Does anybody have the schematic?

 

Cheers

2020_01_25_23_21_13_Gas_heater_driver_PCB_Spark_generator_Page_1_Microsoft_Edge.jpg

Edited by Tsvetomir
Link to post
Share on other sites
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...