Jump to content
Sign in to follow this  
geemurray

Water Pump Issue -1990 Abbey Surrey

Recommended Posts

Hi. I have a question about the water pump on my 1990 abbey surrey. the 12v control panel has a switch to turn the pump on with a green light above and an orange light below to show when the pump is running. the problem is that the green light does not come on when i turn on the 12v supply. does the pump have to be connected or should the green light be on whenever the switch is on? the battery seems charged ok and the other 12v items work. this is my first caravan and although i have the original manual its not very specific to this model. any comments would be appreciated. thanks

Share this post


Link to post
Share on other sites
Guest Delvey

I'd imagine the pump would need to be connected to complete the circuit for the light to come on

Share this post


Link to post
Share on other sites

Normally when you have a power light and pump running light the green light comes on directly you switch the switch on. The orange light comes on when a circuit is made either by pressure switch or micro-switches on taps, whichever system is fitted. The pump need not be connected for lights to work.

Edited by birdman101

Share this post


Link to post
Share on other sites

thanks for the replies. traced it to a bown fuse. now fixed and used on our first trip away this weekend.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...