Jump to content

Lunar Chateau 470 12v Prob


jbrines
 Share

Recommended Posts

Hi Guys,

 

I have a Lunar Chateau 470 2003 Model.

 

Just recently the Fridge won't work while connected to the Car and the Red Light doesn't come on. Is there a Fuse that deals with this? I know there is a fuse under the front seat next to the door but I was wondering if there was another as I can't see it?

 

Thanks

 

John.

Link to comment
Share on other sites

Hi Guys,

I have a Lunar Chateau 470 2003 Model.

Just recently the Fridge won't work while connected to the Car and the Red Light doesn't come on. Is there a Fuse that deals with this? I know there is a fuse under the front seat next to the door but I was wondering if there was another as I can't see it?

Thanks

John.

38640[/snapback]

I have a 2003 Chateau 500. I am 99% sure there is no fuse in the 'fridge circuit.

If my fridge packed up, I would take the fridge vent grills off and look inside the cavity behind the fridge. You will see a white connector that feeds the 12v to the fridge. Pull the connector apart. If you look with a test meter set on ohms, it should show a circuit as you look towards the fridge - assuming it's switched on. If you don't see the meter read, the fridge could be faulty.

Looking in the other direction on volts, you should see a a good 13 volts when the engine is running. If the voltage is not present, the fault lies toward the car.

I have two fuses near my charger. One is in the battery supply, the other is in the charger output.

The Chateaus really do "keep it simple"!

Yours

Dave

Link to comment
Share on other sites

 Share

×
×
  • Create New...