Jump to content

Thetford C402 Toilet Will Not Flush!


harvomark

Recommended Posts

Hi,

 

thetford C402 toilet will not flush, check power feed but when button pressed nothing :( would this be the control panel?

 

Thanks in Advance.

Link to comment
Share on other sites

Not too sure about the model but if you open the outside door, pull out the cassette and look inside, you may find there is a 3 amp fuse in there that has blown, Always check the easiest things first. Good luck Peter :rolleyes:

Link to comment
Share on other sites

Hi Peter,

 

I checked the fuse not blown, then checked that there was power getting to the circuit board and power was there, when button pressed nothing, i need to find out whether it would be the circuit board gone or maybe the pump, any tips on finding out which one is the issue?

Link to comment
Share on other sites

It is probably the pump has failed.

If you have got to the PCB, th epump is below it, check the impeller to see if ti is free turning, if not, the pump has failed

Link to comment
Share on other sites

Try activating the pump and watch the bathroom lights. If they dim slightly it looks as though the pump is jammed.

Link to comment
Share on other sites

Thanks,

is the pump a repairable part or just buy a new one, are they easy to change?

 

P. S.

 

Will the pump work off 12V? as i have no power in storage

 

Thanks

Link to comment
Share on other sites

They are not repairable, so it is a new one, and they only work on 12v.

They are easy enough to change, if a bit fiddly, but you will need a heatgun to shrink the heatshrink sleeve which covers the joint you make in the cable.(and a pair of crimp pliers, side cutters and cable insulation stripper.)

Link to comment
Share on other sites

The pump runs off the 12V system so provided there is life in your battery it should work. There are other threads on how to remove pumps. The limit of my advice would be to use a small screwdriver to check the impellor turns and is not jammed.

Link to comment
Share on other sites

Thanks for all the replies, got to the pump and was jammed. Managed to free the pump up sprayed it with silicone spray now working fine.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...