Jump to content

Toilet Trouble Again


gypsy queen
 Share

Recommended Posts

Once again the toilet is proving some problems.

 

It seemed the batteries were needing replaced for the cassette full but I could not find them and just muddled through. Emptying toilet every day so there was not a heavy toilet to empty.

 

Now the light has come on and stays on whether the cassette is in or out. Still cant find any batteries to replace only a blade fuse which I changed but light stayed on. Any advice greatly received. Thanks

Link to comment
Share on other sites

Not knowing what toilet you have but I think you will not have any batteries in the toilet as the power comes from the main battery (12v) and is fused with the blade fuse .

 

 

This Manual might help. http://www. thetford. com/HOME/PARTS/PermanentToilets/CassetteC200CWSCS/tabid/568/Default. aspx

 

 

 

 

Dave

Link to comment
Share on other sites

On mine the batteries are inside the cassette locker near the top on the left hand side - 2x AA's

Edited by sgthakeswell
Link to comment
Share on other sites

Well if the light is on then the batteries either don't need changed or as is most likely yours runs from 12v.

 

If the light is staying on I would check the reed switch has not become detached and is hanging near the float magnet.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...