Jump to content

2010 Lexon Microwave


peterat49
 Share

Recommended Posts

Hi there

We have a 2010 Lexon 570 with the Daewoo manual (knobs on) microwave.

We do use it a fair bit for various bits and pieces but after about 10 minutes it cuts out and will not work for another 15 minutes or so. This makes using it a pain. It seems to be getting very hot around the top knob, which sets the power level. We are getting another one under warranty, but has anyone else suffered with this microwave or have we just had a bad one?

Thanks.

Peter

Link to comment
Share on other sites

Does it have enough ventilation around it during use? We have the same one in our Pegasus and it vents into the cupboard next door - I always open the cupboard door when using it for more than a minute or so otherwise the cupboard gets quite steamed up and it's got the electric socket for the microwave right underneah the vent - I think some have made modifications to move the socket due to moisture created by the microwave itself. It may be overheating, but then that's for Lunar to sort out!

Link to comment
Share on other sites

Hi there

Thanks for the reply.

I thought that the ventilation looks a like sparse and that the microwave is housed in too tight a cupboard.

Will have to see what the dealer says when it goes in for it to be replaced.

Thanks.

Peter

Link to comment
Share on other sites

The Daewoo microwave in our 2011 Ultima 560 (based on the Lexon) has a ventilation mushroom which comes out of the roof and a circular vent which comes out of the side wall.

We never get any moisture problems or faulty workings.

Lunar Ultima 560 towed by VW Tiguan 2. 0TDi

Link to comment
Share on other sites

Hi again

Checked the vents for the microwave.

We have one under the microwave above the cooker, one on the outside wall behind the microwave and one above the microwave (the mushroom).

All seem clear.

It is pointing to a duff microwave.

Thanks.

Peter

Link to comment
Share on other sites

 Share

×
×
  • Create New...