Jump to content
Sign in to follow this  
cymro123

Orion Fridge

Recommended Posts

Picked up our new Orion last week, and testing everything before we go off in it. Did have a talk thru by the salesman but so much to take in. .. Only problem I have found is the fridge and I suspect it is something I am doing incorrectly. It is working on the gas, but when I try and connect to the mains at home does not seem to cool.

 

 

 

I have tried various things. Checked the tv and that works off the mains. Switched the rcd and mains switch on the control panel off. Switched them back on but still fridge would not cool. When i open the fridge the light comes on so I suspect something silly I have forgotten, Any ideas please.

 

One question, do I have to have the mains power switched on on the dc control panel??

 

 

Thanks

Share this post


Link to post
Share on other sites

Do you have it set to mains on the selector switch?

 

How long have you left it on for, takes hours for it to cool. We leave ours on overnight before going on a trip and it's fine in the morning.

Share this post


Link to post
Share on other sites

Yes I have set it on mains and left it overnight. I think I may have set the temp too high by turning the switch to the wrong side i. e right instead of left. Set it on gas which is indicated by the red line on the green background on the meter, and set the temp switch to the lowest setting ( I hope)

Share this post


Link to post
Share on other sites

Coolest setting is with the dial fully clockwise.

Share this post


Link to post
Share on other sites

Found this on the 'net:

 

"My fridge will work on the gas mode but it will not work on 240 mains. The green light is on and this tells me there is power to the fridge. Please can you advise what might be the problem.

 

 

A friend of ours had a similar problem and when he took his caravan back to the dealer, they advised that it was a faulty element on the fridge. They changed the element and now his fridge works fine. I would advise that you take your caravan back to your local dealer and ask them if that is the cause of your problem and if so ask them to rectify it."

Share this post


Link to post
Share on other sites

Yes a failed element is common on a Dometic fridge. Is it a Dometic?

 

But this is a new fridge, i would suggest you check that the fridge is plugged in, look for a socket outlet near the fridge, on the floor.

 

Check the socket for power, plug an appliance in to test, if you get power then check the plug head fuse, replace with the same rating if that is the problem.

 

You can get a idea if the element is working by feeling for heat at the back of the fridge, remove the bottom fridge grill on the outside of the caravan, you should see two sets of cables going down to the elements.

 

Otherwise get the dealer to send someone out, they sometimes do this with fridges.

Edited by xtrailman

Share this post


Link to post
Share on other sites

Yep, I missed the obvious, check it's plugged in :(

 

The fridge is plugged into a socket inside the flap beneath the cooker.

Share this post


Link to post
Share on other sites

Just noticed that the light is coming on so must be plugged in :rolleyes:

Share this post


Link to post
Share on other sites

Just noticed that the light is coming on so must be plugged in :rolleyes:

The light in the fridge runs off the leisure battery. Have you tried plugging a lamp or hair dryer into the socket that feeds the fridge. At least then you know you have mains electric to the fridge. Are all the mains breakers in the up position.

Share this post


Link to post
Share on other sites

The light in the fridge runs off the leisure battery. Have you tried plugging a lamp or hair dryer into the socket that feeds the fridge. At least then you know you have mains electric to the fridge. Are all the mains breakers in the up position.

 

Didn't know that (obviously :lol:)!

Share this post


Link to post
Share on other sites

Well hope it's not another Thetford Fridge. ..Our Brand new Olympus 546 had to go in after a couple of months as our fridge stopped working on 240v mains would not get cold and we plugged it i over night. It had to have a new fridge last month as the element had gone. Would work on gas though ! I have heard that quite a few Thetford fridges have had this problem. Hope yours isn't the same :(

Share this post


Link to post
Share on other sites

Well hope it's not another Thetford Fridge. ..Our Brand new Olympus 546 had to go in after a couple of months as our fridge stopped working on 240v mains would not get cold and we plugged it i over night. It had to have a new fridge last month as the element had gone. Would work on gas though ! I have heard that quite a few Thetford fridges have had this problem. Hope yours isn't the same :(

 

 

Seems a little strange that the manufacturer is replacing the whole fridge for the sake of a faulty 240 element. Not common practice for them to give more than required.

Share this post


Link to post
Share on other sites

Checked everything I can, plugged in a radion itno the socket and it worked. Will have to call the dealer today to get it sorted, it is a dometic fridge.

Share this post


Link to post
Share on other sites

Looks ok now, I was turning the temp switch clockwise as it stated in the manual, should be anti clockwise. Running it on gas now and seems to be cooling. thanks for all the advice.

Share this post


Link to post
Share on other sites

Looks ok now, I was turning the temp switch clockwise as it stated in the manual, should be anti clockwise. Running it on gas now and seems to be cooling. thanks for all the advice.

 

Thats odd, on my second Dometic fridge, both turn clock wise to increase cooling.

 

Problem we have with ours is the fridge goes too cool if we set it as we did with our previous caravan, that was around 20 past to half past (clock face).

 

With the new one it only needs 10 past the hour position.

 

I have found the unicorn manuel has errors also, i don't think any one actually checks them for accuracy, par for the course really.

Share this post


Link to post
Share on other sites

Would have thought all Orions were the same. Ours has a Thetford N112 fridge and fully clockwise is the coolest position.

Share this post


Link to post
Share on other sites

Sorry sorry sorry, you are right Whatever it is a Thetford. So much going in my head must have read something somewhere. the temp switch has large spots clockwiase and small spots anti clockwise(sorry for the technical terms) I have been told by dealer to start it up with the switch set vertical between them to cool it first time. Does that sound right?

Share this post


Link to post
Share on other sites

Sorry sorry sorry, you are right Whatever it is a Thetford. So much going in my head must have read something somewhere. the temp switch has large spots clockwiase and small spots anti clockwise(sorry for the technical terms) I have been told by dealer to start it up with the switch set vertical between them to cool it first time. Does that sound right?

 

As you said, you get told that much at handover you forget some of it. I just followed the manual and had it on for at least 8 hours before putting stuff in it. Always had it set max clockwise and everything is nice and cool + ice cream stays hard in freezer compartment.

Share this post


Link to post
Share on other sites

letting it run overnight now, see how it is in the morning

 

 

 

~Thanks

Share this post


Link to post
Share on other sites

Looked at it this morning still the same. So I sat down tries to think logically and noticed that the master switch on the control panel was off. I take it that this has to be on to cool the fridge on either elec or gas. I read in the manual that the fuses need the control switch on. Is this correct.

 

 

 

Trying again now, if this works please accept my apologies for being so silly, but as i said new to all this and so much to take in before we go away.

 

 

 

John

Share this post


Link to post
Share on other sites

Looked at it this morning still the same. So I sat down tries to think logically and noticed that the master switch on the control panel was off. I take it that this has to be on to cool the fridge on either elec or gas. I read in the manual that the fuses need the control switch on. Is this correct.

 

 

 

Trying again now, if this works please accept my apologies for being so silly, but as i said new to all this and so much to take in before we go away.

 

 

 

John

 

The master switch controls the 12v supply. Wouldn't have thought this would affect a 240v appliance but we'll know soon!

 

When I cool mine overnight I do it on gas and when on EHU I have the master switch on so hopefully you're right.

Share this post


Link to post
Share on other sites

On the unicorn the master switch is off, when we cool the fridge at home, on the mains.

 

It only goes on when we arrive at site.

Share this post


Link to post
Share on other sites

We have an Orion 450-5, which we have just brought back from its second outing.

 

Unfortunately it seems like we have dud fridge too. When we arrived on site we put just a few meagre items in there over night (so it was pretty much empty). We went shopping the next day and put our goodies away. My wife checked it later and found the chips in the freezer compartment had defrosted.

We had to throw loads of food away. We filled a segment of the icecube tray and put it in the frezer, after two days, it had still not frozen.

 

We had the master switch on and the selector switch to mains. I am pretty sure it is a fault as the internal light was working, and the interior was cold, just not cold enough.

 

Needles to say I shall be contacting the dealer about this as it will have to be put right, at his expense, before our next trip.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...