Jump to content

Just About To Go


jaymac
 Share

Recommended Posts

Can anyone explain why the mover seems to've stopped working? The battery is fine. showing a green light on the handset but nothing is happening and of course there's no one at Powr products today. Inside the van there's a red light showing on the Powrtouch box and when we try to start the mover it just flashes. we're meant to be on the 10 am ferry tomorrow!

Mine: Fiesta; his Mondeo Estate; ours Bailey Olympus534, DD1's Poppy the cocker but she comes with us!

Link to comment
Share on other sites

Can anyone explain why the mover seems to've stopped working? The battery is fine. showing a green light on the handset but nothing is happening and of course there's no one at Powr products today. Inside the van there's a red light showing on the Powrtouch box and when we try to start the mover it just flashes. we're meant to be on the 10 am ferry tomorrow!

 

 

is there a reset, if not, try disengaging rollers kill power to mover, reverse the for mentioned and try to push the van a shortdistance, may be just a little bit of siezing after not being used for a while.

nigel

NIGEL129 Hobby 495 Ufe (2003)

Powrtouch HD BP GAS Lite User Toyota Surf 2. 4 Tug,

Link to comment
Share on other sites

Thanks Nigel, we'll try that but it was working happily yesterday. Any other ideas anyone? OH isn't too happy to set off on a six week trip to France without the mover!

Mine: Fiesta; his Mondeo Estate; ours Bailey Olympus534, DD1's Poppy the cocker but she comes with us!

Link to comment
Share on other sites

Can anyone explain why the mover seems to've stopped working? The battery is fine. showing a green light on the handset but nothing is happening and of course there's no one at Powr products today. Inside the van there's a red light showing on the Powrtouch box and when we try to start the mover it just flashes. we're meant to be on the 10 am ferry tomorrow!

 

Hi Jaymac. This happened to me with my Powertouch.

 

If you have the electronic engage system then same as me if not still try this.

 

 

When I called them they told me to disengage the motors.

Make sure the switch is in the centre (off) position.

Turn off the big red key and REMOVE it.

wait 20 seconds and try again. Apparently this resets the system.

 

This worked for me so I hope it works for you good luck.

 

If you are still able to get on the ferry without it I advise you to do that and call them out when you get to the site.

 

Brian

Edited by Bwy

Tugging a Bailey Senator Vermont Millennium

With a 1999 Vauxhall Frontera Diesel 2. 2 Automatic

Link to comment
Share on other sites

According to my manual, there are two lights on the control box in the van. Both should normally be steady. The green light flashes if the van battery is not fully charged. The red light only flashes if you have done a manual reset and this involves taking the cover off the box. Pressing one of the direction arrows on the handset pairs handset with box and red light goes steady.

 

There is a trouble shooting section on the Powerwheel web site but I don't think it will help.

 

If you have left control box switched on it switches itself off after a short time. You have to reset it by switching off for at least 15 secs.

 

Alternatively have you thought about using emergency cable.

 

If motors turn but there is no drive then it is a matter for factory.

 

Sorry but manual offers no more help.

 

Poole bob

Honda CRV Diesel Petrol & No caravan now. :angry:

Link to comment
Share on other sites

Thanks for all your help, I don't know what he's done but it's sorted! Dover here we come!

Mine: Fiesta; his Mondeo Estate; ours Bailey Olympus534, DD1's Poppy the cocker but she comes with us!

Link to comment
Share on other sites

Thanks for all your help, I don't know what he's done but it's sorted! Dover here we come!

 

 

aw, cum om, letus know how it was fixed

well done, enjoy your break and give those of us stuck at home due to commitments a thought.

nigel

NIGEL129 Hobby 495 Ufe (2003)

Powrtouch HD BP GAS Lite User Toyota Surf 2. 4 Tug,

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...