Jump to content

Not New To Caravans But New Here With Water Problem?


leeandoona
 Share

Recommended Posts

Hello everyone. Tried to post in the Caravan chat forum but for some reason not able to do so hence posting here.

 

We've had our Caravan for over a year, it's a 1992 Envoy, 4 berth with a standard water pump (from the aqua roll direct to water heater or cold taps). About 6 months back we started to get little black granuals appearing in the cold water, the problem has slowly got worse until now, our cold water only trickles out of the taps and has loads of black granuals in what we do get. Hot water is fine and pressure is fine on this also.

 

I've checked the pump that goes to the aqua roll and it's fine, have swopped it for a spare and problem is same. Has anyone else encountered this issue and do you know what the problem is?

 

Thanks all in advance

 

Lee and Oona

Link to comment
Share on other sites

If you have a water filter fitted, it sounds like it has disintegrated.

 

Hmmm. Yes I thought that but am not sure where the filter is other than the built in filter on the submersible pump. Any ideas where a filter is? Not very good with plumbing!!!

Link to comment
Share on other sites

About 6 months back we started to get little black granuals appearing in the cold water, the problem has slowly got worse until now, our cold water only trickles out of the taps and has loads of black granuals in what we do get. Hot water is fine and pressure is fine on this also.
Hi,

It sounds very much like the advice already given is correct and finding the filter is key to resolving this. It may be located immediately to the rear of the water inlet, or incorporated within the inlet and be accessible from outside of the caravan. It could also be mounted anywhere along the cold water feed pipe within the caravan. The carbon granules you are seeing indicate a failed filter, but in addition the feed pipe may also be flattened (squashed flat, or bent round a tight radius) causing a restriction of the flow.

Tried to post in the Caravan chat forum but for some reason not able to do so hence posting here.
All new members are required to make their first post within the three "Welcome" forums in order for us to validate them as "Approved Members".

Kind Regards,

Gordon.

Fourwinds Hurricane 31D Motorhome. Also MGTF135 1. 8i Roadster (fun) & Volvo V70 3.2Ltr LPG (everyday car)
Unless otherwise stated, my posts will be my personal thoughts and have the same standing as any other member of Caravan and Motorhome Talk.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...