Jump to content

Recommended Posts

Just become the owner of my first Bailey Autograph lll 74-2 

Apparently there is a known fault with the panel while on DC power only in as much as it displays low vehicle battery voltage despite battery being fully charged!It also appears that due to this error the panel does not permit you to transfer over to chassis battery presumably because of the low power shown.

Everything  on the panel displays correctly when on 230 volt.

Has anyone out there had similar experiences?

Thank you.

Iain

Link to post
Share on other sites

Hi Iain

If the panel works ok on 240 volt it sugests the leasure battery (12 volt supplied by the onboard charger ) is faulty most panels shut down at 10 -10.5 volt

best place to start fault finding :-I would remove the leasure battery at get it   dropTested / heavy discharge at at car parts shop ie halfords to see if 1 cell or move are faulty 

check the terninals on the battery are clean and tight and the fuse near the battery norm about 30-40 amp a muti meter would help trace a fault

Dave

Link to post
Share on other sites

I would email BCA leisure service department to see if they can help. 

Link to post
Share on other sites
4 hours ago, Iain C said:

Just become the owner of my first Bailey Autograph lll 74-2 

Apparently there is a known fault with the panel while on DC power only in as much as it displays low vehicle battery voltage despite battery being fully charged!It also appears that due to this error the panel does not permit you to transfer over to chassis battery presumably because of the low power shown.

Everything  on the panel displays correctly when on 230 volt.

Has anyone out there had similar experiences?

Thank you.

Iain

Hi Iain, welcome!

 

As it’s so new the obvious action has to be revert back to your dealer - or did you buy it privately? 
 

No personal experience of BCA CS but you could try them as also suggested above. 
 

I found a few other forum posts with similar issue but none give the solution, it’s so annoying when they end in the dark (so do pop back and let us know of you do sort yours please) - one did suggest turning off battery level alarms but not sure it would help in your case. 

Cheers, Martin

Link to post
Share on other sites

Hi guys and thank you for your interest shown in my case.

 Yes The van is brand new on a 21 plate and picked up with 4 miles on the clock.

I had to have lots of the usual snagging done over 2/3 days at the dealers and all were fixed with the exception of the panel fault.

This is our 6th new Motorhome and the snagging was not much worse than any others.Not that I am saying this is acceptable but seems to be more the norm than the exception!!!

The dealer informed me that the panel fault is known to the electronic company and apparently still to be resolved.I have had confirmation from the dealer that the company is still investigating matters but still no fix!! 
The purpose of my earlier communication was just to test the water to find if any other owner has had or still having this problem.

I did attempt to alter the settings on the panel to omit the chassis battery information but have been unsuccessful in my attempts.

Thank you for your interest and I  will post again if any progress is made.

Link to post
Share on other sites

Have you tried going into settings and disabling the notices function. 

Kia KX 3 auto / Bailey Alicanto Grande Estoril and Swift Challenger 570 (2010 model Not towed - used as a static)
 

Link to post
Share on other sites

Yes Alan I have but to no avail!!!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...