Jump to content

Powrtouch works then won't


Recommended Posts

Hi , my powrtouch eco motor works fine for how ever long I wish to move it 10 seconds /1 minute / 2 minutes  etc but once I stop it and then try to use it again nothing , tried removing big red isolation switch then putting it back , nothing ., had new 110amp leisure battery fitted  start of July 2020 and have tried 3 new handset batteries still same problem , mover was 5 years old February 2020 so out of guarantee , any ideas , thanks Pete 

Link to post
Share on other sites

Try contacting Powrtouch as they are known to be quite helpful. 

  • I agree completely 2

Graham

 

Unless otherwise stated all posts are my personal opinion 

Link to post
Share on other sites

Ditto contacting Powrtouch - never found another manufacturer who understands their products as well as they do.

Tech Support all working from home at the moment because of Covid, but you will get a response by phone or email.

 

 

Cheers

Keith 

Link to post
Share on other sites

New batteries in the remote.

Link to post
Share on other sites

I had a problem with mine when it was relatively new it would start then stop after about 10ft  . Phoned Powertoutch up and spoke to a chap that sounded like a proper engineer he new exactly what to check it was loose connection my dealer hadn’t tightened!  I remember thinking wow a phone diagnosis..he knows his stuff !

2019 Ford Transit DCIV Limited 190bhp Auto / 2007 VW Transporter Kombi 2.5 TDI 174bhp  4 Motion  +  2018 Bailey Unicorn lV Valencia 

Link to post
Share on other sites

We had a similar problem. I tried and tried to find the cause. Eventually found it. The battery isolator switch was not making a good contact when closed. I changed it and never had another problem.

Ern

Link to post
Share on other sites
1 hour ago, Benfica said:

New batteries in the remote.

+1

If the remote batteries are good when you press any direction button the adjacent red LED will light: if the batteries are dying when you press any direction button ALL of the red LEDs will light.

Edited by Woodentop

2018 Passat B8 Estate 150GT TDi150 towing a 2018 Bailey Unicorn S4 Seville

Link to post
Share on other sites

Another possibility is the remote controller battery fit. The 9V batteries are not all the same size. Some are a bit shorter in length and require a paper wedge pushing in to take op the slack. The design of the battery location is reliant on this fit. Have a look and you will see what I mean.

Ern

Link to post
Share on other sites

Hi thanks for the quick replies , I'm going to try all the things surgested, as I said 3 new batteries in hand control so far , the new battery I'm having tested so see if it faulty and I'm going to give powrtouch a call today , what I can't understand is why it works then won't ,pete

Ern, perhaps while holding handset battery is slipping down slightly so I'll give your tip a go , you never know , thanks pete

Link to post
Share on other sites

Sorry I haven't had time I'll get onto it soon and report back , thanks Pete 

Link to post
Share on other sites

The slides the rollers move on should be lubricated twice a season with spray motorcycle chain grease.

Failure to do this resulted on the rollers on mine failing to motor.

Here s is a link showing how to do it.

https://www.powrtouch.com/greasing-the-evolution/

 

 

Link to post
Share on other sites

on our first powrtouch, we had a loose wire in the handset, it came loose by pulling the battery out to change it. As we didn't have a solder  kit we took it to a TV repair chap and he soldered it for us.

Link to post
Share on other sites
×
×
  • Create New...