Jump to content

whale aquasource


Recommended Posts

I have a Bailey Virgo and when I connected to  the above, water did not  flow from the taps.  The supply hose was very long could this have been the reason?

 

Regards

Link to post
Share on other sites

Was the water pump switched on? 

Graham

 

Unless otherwise stated all posts are my personal opinion 

Link to post
Share on other sites

The black edition Vigo does not have an onboard pump    When you disconnect the exterior pump and connnect the Whale Aquasource  which has a built in  pressure valve water should flow, mine doesn't

 

 

 

 

 

Edited by WJG
Link to post
Share on other sites
2 hours ago, WJG said:

The black edition Vigo does not have an onboard pump    When you disconnect the exterior pump and connnect the Whale Aquasource  which has a built in  pressure valve water should flow, mine doesn't

 

Have you tried the Aquasouce as a hosepipe...  Whale say this 

 

Quote

Can be used as a hose pipe by fitting the plug adaptor to the plug which will allow water to flow

 

Quote

Kit includes:

  • 7.5m lay flat hose
  • Whale Plug
  • Tap to hose connector
  • Plug Adaptor compatible with Truma Ultraflow Sockets

 

If it works as a hose then the problem is with the caravan plumbing.  If it doesn’t then the pressure regulator must be suspect.

Edited by ReggiePerrin
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...