Jump to content

Control Panel Water Pump issue


Recommended Posts

VIP 575 Caravan just back from 2nd Service, after been held in quarantine for the last 12 wks, as it went in to Dealers on 21 Mar 20 then Lock Down came.

 

So I am now Glad to have my caravan home again, so setting up all systems ie water and came across this problem,

 

(refer to video demo.) Too large but I will reduce size and issue later 

 

the water symbol disappears as it should when tap is closed, but opening the tap again no water runs until I push the Control Panel on/off/on again.

and same happens each time I close the tap.

 

anhbody came across this problem as I think it’s more the Control Panel buttons above the door rather than the pump itself 

 

(all whale systems are calibrated )

Edited by PapaT

Mercedes Benz GLC 250d Sport, towing Coachman VIP 575 2018

Link to post
Share on other sites

I would tend to lean towards it being the pressure switch. You say you have Whale system. I seem to recall reading that the electronic switch can be “sensitive” to voltage. Are you on EHU or battery. Is your battery well charged. 

Link to post
Share on other sites

I am on EHU at home with a well charged battery also. 

 

caravan dealer issued a new submersible pump, as they couldn't get the system during service to cut off and hold pressure, 

so Ive calibrated the new pump, and the system worked, and on closing the taps the run on time did take longer but it did cut out. but now came across this issue, as I could only get the pump to re start once I had pressured the control tap button to put it off. then repress to put the pump on.

 

so your saying the pressure switch maybe the fault??

 

 

Mercedes Benz GLC 250d Sport, towing Coachman VIP 575 2018

Link to post
Share on other sites

Your original post led me to suspect the pressure switch. Your second post just seems to reinforce this. 
 

10 hours ago, PapaT said:

caravan dealer issued a new submersible pump, as they couldn't get the system during service to cut off and hold pressure, 

This rang alarm bells. Sounds like they were clutching at straws. 
The water pump system on caravans is fairly simple. Water is pumped in until a pressure is reached. Pump stops. When pressure drops pump starts. 
In order to prevent the water running back to the pump,( resulting in pressure falling ) there is a non return valve. Often these leak. This results in pump pulsing on /off at regular intervals. The leaking is normally due to a tiny bit of muck that’s got trapped in the valve. 
You have the electronic pressure switch. Turning the power off then on causes the pump to run.

Try just turning the pump power off / on and see if the pump still runs, even though your not demanding water. That would again raise suspicions of the pressure switch. 
 

Link to post
Share on other sites

thanks for comments, and this morning I revisited the pressure control until and recalibrate the switch, and all go this time.

 

so all day ive been going in and out of caravan, opening and closing the taps, and all is working as it should be doing. 

 

first time must have been a fluctuation in power, and the sensitivity got the better of it.

 

caravan now sitting all plumbing in, with EHU connected as if am on holiday, and aqua roll full of water and sterilisation tablets, so the taps will be on/ off a lot over the next day.

 

hopefully we will be on tour shortly, as its been a Low Mileage year so far.  

 

PapaT

Mercedes Benz GLC 250d Sport, towing Coachman VIP 575 2018

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...