Jump to content

The dreaded Thetford Toilet Flush....


Recommended Posts

Hi all,

 

I wanted to say first that I find this forum exceptionally helpful and you are all incredible at sharing your knowledge.  For a newbie to the world of caravans, it's been a gold mine so far.

 

Having said that, I too have been a victim of the dreaded thetford toilet flush issue.

 

I have lifted the sticker, checked the PCB and connections, pulled out the pump and rotated the impeller with a small screw driver, and cleaned the pump as best I could.  Nothing.

 

Now, I have a few specific questions and I wonder if any of you wonderful people can help me.

 

1st, I have an Adria Adora 613 UT Thames (2016), if this helps.  I have searched high and low in the waste tank locker for any sign of a fuse box and cannot see anywhere to put a blade fuse.  I do however have a compartment at the back where there is another PCB type board.  Is this the fuse system for the toilet?

 

Also, looking at the general blade fuse board inside the van, there are various fuses obviously and I found that one 5A fuse had blown and it was inserted in a slot labelled "Fire".  I replaced the fuse but it immediately blew again.  May be irrelevant .... not sure.

 

Also, my brother-in-law (who I got the caravan from) insists that there is a battery pack somewhere that controls the flush.  Now I cannot find this for love nor money.  Any ideas about that? I've had a look at forums and searches and the best I can come up with is that some thetford have a separate battery pack to control the waste level indicator?  Not sure that's what's at work here.

 

I've attached some pictures, including the waste locker area with various views of the wiring and also the make/model/DNA of the toilet.  Apologies for the grubby appearance, I'm still cleaning this bad boy after it was in storage for over a year.  Not the nicest job I must say.

 

Thank you all so much for taking the time to read and your feedback is so appreciated.  

 

Best,

 

PK

 

 

20200312_100854.jpg

20200312_100857.jpg

Link to post
Share on other sites

There will be no battery pack. It's possible that the toilet is wired up to that fuse. Try unplugging the pump and PCB and replace the fuse and see if it blows. You could also do with a way to see if power is getting to the pump when you press the flush button

Link to post
Share on other sites
Posted (edited)

Cheers, I'll give that a go.

 

I really thought there wasn't a battery, he was just so adamant that there was one! :) thanks for confirming.

 

If it doesn't blow when disconnected from the PCB and pump, its probably either the board or the pump is knackered then?

Edited by NewbieAdora2020
Link to post
Share on other sites

Yes see if the fuse still blows with it all unplugged, it's a start to finding the fault, that's if it is wired to the toilet. You will see in you local caravan accessory shop that pumps and PCBs are readily available as they do like to fail now and then

Link to post
Share on other sites

The toilet has a wiring harness that connects to the caravan 12v supply, probably near the outside wall as it will likely run along the floor. Follow that and it will lead to the pump, the 'full' level pcb, the flush panel pcb and the fuse. Look very carefully at all  connectors themselves, and the pcb tracks to which they connect. They are all prone to corrosion to the extent that the pcb tracks can corrode to nothing in some locations. Cleaning these may provide a temporary solution but its better to replace in the end. Thetford diagrams and part numbers are available on the support part of the Thetford site.

Link to post
Share on other sites

Look on u-tube information on there about thetford toilet fuses/pumps etc guy called Dan trudgian 

now retired and loving it

Link to post
Share on other sites

Update:  I've replaced blown fuses and they are holding, no blown replacements.  But...

 

Still no flush!

 

Think the pump has had it?  Also there is a little bit of blue corrosion on the connector to the PCB.   Maybe that's causing failure too?

 

Headache 

Link to post
Share on other sites

It might be a case of biting the bullet and buying a new pump and if not that then a new pcb

Link to post
Share on other sites

If the pump is removable, connect it directly to the 12V battery via a fuse and see if it turns.

The difference between a master and a beginner

The master has failed more times than a beginner has ever tried.

Link to post
Share on other sites

Switch the washroom light on and press the flush button.  If the light dims, (may be imperceptible in daylight if LED lighting) the pump is getting power but is inoperative /seized.

 

If the light doesn’t dim then no power is flowing to the pump.   Fuse or flush button are the primary suspects.  A seized pump may blow the fuse.


Have a read of this  - it relates specifically to the Thetford 262CWE that you have.

 

 

Link to post
Share on other sites

Have you seen my video. Even if you wires are still attached the contacts on the circuit board corrode.

 

Mazda CX5 2.2d auto 184bhp Ace Supreme Twinstar TA

mazda cx5 icon.jpg

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...