Jump to content
Sign in to follow this  
Organman

Thetford c260 Toilet

Recommended Posts

I had an interesting conversation with Thetford yesterday, It was regarding my continual problem of the supply water pipe that connects from the water pump to the holding tank leaking and allowing water to flood the base area. (see pic and green pipe hi-lighted) apparently Thetford have brought out a modification to this pipe and when i spoke  customer service yesterday they said they would send me a replacement pipe FOC.  

c260 pump.jpg

Share this post


Link to post
Share on other sites

That pipe looks as if it's been cut too short and a tight bend forced on it. The bend may be enough to make the pipe distort as it enters the pump from below.

Share this post


Link to post
Share on other sites

Our toilet is a C250  and a photo of the pump pipes is attached as a comparison. The clip holding the pipe on looks stronger than your tie wrap so might give a better seal. Also possible you have  a crack in the pump nozzle which is leaking so something to check if not already done.

pipes.thumb.JPG.bbd2a516604e39430bb70306492b9765.JPG

Edited by Paul1957

Share this post


Link to post
Share on other sites
1 hour ago, Paul1957 said:

Our toilet is a C250  and a photo of the pump pipes is attached as a comparison. The clip holding the pipe on looks stronger than your tie wrap so might give a better seal. Also possible you have  a crack in the pump nozzle which is leaking so something to check if not already done.

pipes.thumb.JPG.bbd2a516604e39430bb70306492b9765.JPG

That's how mine should be but having searched tinternet for a new pipe I finally resorted to giving Thetford a call I think the customer services said they have also incorporated a drain into the pipe. I will post picture of new pipe when it arrives.

Share this post


Link to post
Share on other sites

Wouldn't a jubilee clip sort it? 

Share this post


Link to post
Share on other sites
52 minutes ago, WispMan said:

Wouldn't a jubilee clip sort it? 

No I tried that, Because of where the pipe attaches to the water tank there are strengthening ribs and you cant get a screw driver in to tighten the Jubilee clip, Im going to have to source some like those on Paul1957 picture.

Share this post


Link to post
Share on other sites

You are fairly lucky that a leak was the only problem with this pipework so far. The same 'U' bend arrangemant saw numerous pumps fail over the years due to the water that was inevitably  trapped in the loop, freeze and smash the pump, that was why Thetford introduced the drain hose to it.

 

Anyone else still with this arangement should contact Thetford and get the mod done, it's free, a quick and easy to do, and could save you forking out a hefty price for a new pump.  Good luck.

 

Dave

  • Thanks 1

Share this post


Link to post
Share on other sites

 

As promised the new pipe has arrived FOC.

1580904040141-73394125.jpg

Share this post


Link to post
Share on other sites

New pipe fitted

1580905709696700699410.jpg

Share this post


Link to post
Share on other sites

Well done, a much better design than the original too.

 

Dave.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...