Jump to content
Sign in to follow this  
Lureman

pump ticking and lights flickering

Recommended Posts

We used our caravan last night for the first time and when we turned the tap on we could see lights flickering and we could hear a ticking sound, Any ideas please ?

 

Daz

Share this post


Link to post
Share on other sites

It sounds like your pressure switch needs adjusting.  It’s normally located near where the water enters the van. It will have a knob on the top, and two wires going to it.  I find the best way to adjust is with a tap running fully on, adjust the knob 1/2 turn at a time until clicking stops, then turn tap off, any make sure pump stops after a few seconds. Repeat until it works. 

  • Thanks 1

Share this post


Link to post
Share on other sites
2 hours ago, Lost in the wilderness said:

It sounds like your pressure switch needs adjusting.  It’s normally located near where the water enters the van. It will have a knob on the top, and two wires going to it.  I find the best way to adjust is with a tap running fully on, adjust the knob 1/2 turn at a time until clicking stops, then turn tap off, any make sure pump stops after a few seconds. Repeat until it works. 

 

sorted, Thankyou very much :Thankyou:

Share this post


Link to post
Share on other sites

It's worth noting that if you are off grid (battery or battery & solar) the pump may need to be slightly adjusted compare to on EHU. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...