Jump to content
alfiemorris

Truma water heater won't light on gas.

Recommended Posts

It lit when we arrived off grid yesterday. Igniter is heard to click but red light comes on after about a minute. Any help or advices please? 

Share this post


Link to post
Share on other sites

Truma Ultra store Brecon. 

Share this post


Link to post
Share on other sites

Ok, thanks.

First I suppose that you have removed the cover from outside?

Second, the gas isolation valve is open?

Third, you have tried several attempts to light it? it can take quite a few attempts if it has not been used on gas for some time.


If the answer is yes to all above, then it suggests a problem with the PCB.

Share this post


Link to post
Share on other sites

Yeah, all other checks done, even a new gas bottle. Oven, fridge all working OK. I had assumed PCB but we'll just have to go without the boiler? Very difficult to reach as the boiler is well tucked away up front corner. 

Share this post


Link to post
Share on other sites

The only other thing that may be causing the problem is lack of gas through a blocking regulator but that would depend on what reg you have on the van.

A quick way of testing is to light the hob with one burner, then light the second and third and see if the flame size changes as each is lit, If the first starts to diminish in size then the reg is failing,

 

This is only applicable to the GOK regulator, not the Clesse ,

Share this post


Link to post
Share on other sites

Just to double-check - when Brecon says ‘isolation valve’ he’s not referring to the one on the bottle, but the separate manifold with 3 or 4 valves controlling each item - it’s usually tucked away under the kitchen sink  and can therefore easily get knocked (apologies if you already knew this).

 

I’ve had the manifold problem, and also the ‘forgot about the flue cowl’ problem, in the past - and my brother had the ‘spider in the gas pipe’ scenario  -  and it’s a relief when you discover it’s something simple and inexpensive.

 

What about electrics? I don’t know the specifics, but I assume there’s either a 12v or AA battery supply to the igniter - have you checked this out?

 

Good luck, John.

 

 

Share this post


Link to post
Share on other sites

Thank you John.  Yes, all taps double checked now. Odd thing is it worked yesterday?  12v off battery and when I looked for fuse on the board all was OK. By the PCB there is another glass type fuse but I can't get to it down past the PCB? 

Share this post


Link to post
Share on other sites

Well before we left the THS on Friday, I tried again without success to get the boiler working on gas. Time to give in.  Out of desperation I went out and just blew as hard as I could up the boiler flue, several times.  Returned to the panel, flicked the gas control up and waited for the Red "failure" light to come on. It didn't.  Now at home and it has now worked three or four times?  So what now?  Carry on I suppose? :blink:

 

NB. I'm tempted to gently fire some air into the flue using my air line?  Without removing the boiler in order to service it, is this a normal thing to do?

Edited by alfiemorris

Share this post


Link to post
Share on other sites
1 hour ago, alfiemorris said:

Well before we left the THS on Friday, I tried again without success to get the boiler working on gas. Time to give in.  Out of desperation I went out and just blew as hard as I could up the boiler flue, several times.  Returned to the panel, flicked the gas control up and waited for the Red "failure" light to come on. It didn't.  Now at home and it has now worked three or four times?  So what now?  Carry on I suppose? :blink:

 

NB. I'm tempted to gently fire some air into the flue using my air line?  Without removing the boiler in order to service it, is this a normal thing to do?

Cobwebs! Time to get it properly cleaned out by a professional.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...