Jump to content

Recommended Posts

Good afternoon, have seen others have had the same issue with the atc led not working, it goes through the self checks fine and all points to faulty led. Has anyone replaced the led only and if so where did you get it from and how to replace it. Thanks for your help

Share this post


Link to post
Share on other sites

Any caravan dealer will get you one, and I think that you can buy directly from Al-Ko (they have an online shop). They come with a short lead that lugs into a multi-plug near the front of the caravan, and ISTR that there’s just a small nut that holds them in place.

Share this post


Link to post
Share on other sites
On 25/07/2019 at 14:07, Daveyandbev said:

Good afternoon, have seen others have had the same issue with the atc led not working, it goes through the self checks fine and all points to faulty led. Has anyone replaced the led only and if so where did you get it from and how to replace it. Thanks for your help

I have stopped replacing mine as they fail on a regular basis and at £30 plus a pop no thank you.

Share this post


Link to post
Share on other sites
6 minutes ago, Hector69 said:

I have stopped replacing mine as they fail on a regular basis and at £30 plus a pop no thank you.

Me too.

Geoff

Share this post


Link to post
Share on other sites

Three caravans over 14 years and not one LED failure.

 

Is it me?

  • +1 2

Share this post


Link to post
Share on other sites
30 minutes ago, shipbroker said:

Me too.

Geoff

And me!

Share this post


Link to post
Share on other sites
Posted (edited)

Somewhere on the forum there was a thread about dismantling the indicator and replacing the bi-colour led only.  Thereby saving many pounds (if you have soldering skills to do so). 

 

This one https://www.caravantalk.co.uk/community/topic/123496-replacement-atc-led/  Only issue is the link to eBay for the LEDs is broken (again).

 

My atc led is also still working (touch wood) and is almost 7 now.

 

Edited by Rodders53

Share this post


Link to post
Share on other sites
28 minutes ago, Rodders53 said:

Somewhere on the forum there was a thread about dismantling the indicator and replacing the bi-colour led only.

 

Yes I looked for it some time back.

 

geoff

Share this post


Link to post
Share on other sites
14 hours ago, Woodentop said:

Three caravans over 14 years and not one LED failure.

 

Is it me?

 

No, you’re not alone. I did have one that looked as though it had failed, but it turned out that an “engineer” (I use the term as loosely as possible!) at the Lunar factory had drilled a hole through the cable under the caravan!

Share this post


Link to post
Share on other sites
Posted (edited)

The LED in our’s failed earlier this year.   I thought that £30+ was a little bit excessive. So I did a search and bought a replacement led online from China. It cost $2.41, delivered.  Actually that was for 100 ofthem.  Chopped the old one off and soldered new one on Inow have a operating  status indicator for the ATC.  

Edited by fred
  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, fred said:

The LED in our’s failed earlier this year.   I thought that £30+ was a little bit excessive. So I did a search and bought a replacement led online from China. It cost $2.41, delivered.  Actually that was for 100 ofthem.  Chopped the old one off and soldered new one on Inow have a operating  status indicator for the ATC.  

What was the exact spec of the LEDs you bought?  (inc dimensions) so that others can find suitable leds to buy?

Share this post


Link to post
Share on other sites

I bought an ebay one too, but I did fit a waterproof connector, as the original used a simple  2 pin connector, completely open to all the elements under the A frame.  Penny pinching by Swift.

Share this post


Link to post
Share on other sites
16 minutes ago, Rodders53 said:

What was the exact spec of the LEDs you bought?  (inc dimensions) so that others can find suitable leds to buy?

That’s what I bought

https://www.aliexpress.com/snapshot/0.html?orderId=100737652314128&productId=32327404087

 

I’m not an expert but they seem to work.    Of course I have about 95 left if someone wants to PM me😉

Share this post


Link to post
Share on other sites

Thank you Fred.  This may help members in the future when locating suitable replacements?  So: For the record these leds are described as:

 

Dual Bi Color Polar Changing Red/Green Led

 

5mm diameter (aka T-1 3/4) , 2-Pin led

Color: Red and Green 
 When input current "+" and "-", Red lit  (+ on long leg, most probably?)
 when input current "-" and "+", Green lit 
 Forward Voltage: 1.8V ~ 2.2V  
Forward Current: 20mA  
Lens Color: Milk-White

 

CPC stock something close but not identical at 25p each.  Ebay etc also have them.   Quite how the Chinese can make and ship 100 to the UK for a few pounds beggars belief.

 

Share this post


Link to post
Share on other sites

Here is my 2p LED in all its functioning glory

IMG-0687 (1).jpg

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks guys looks like I might invest in 1 (100) from China then at that price is worth it lol. On holiday at moment. Fred would you consider selling us half a dozen so we have spares? 

Edited by Daveyandbev

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...