Jump to content
Sign in to follow this  
PF22

Whale water pump

Recommended Posts

Posted (edited)

Hi

 

Had our caravan for about 9 months and it appears second water pump has gone. 

 

Is this normal, or should they last for a lot longer? 

 

Thanks. 

Edited by PF22
Typo

Share this post


Link to post
Share on other sites

They normally last a lot longer, you do not say whether it is inboard or submersible.

Main causes of failure are:-

For submersibles running dry, or pressure switch/microswitches not turning off.

For inboard pumps, frost  while not drained.

  • Like 1

Share this post


Link to post
Share on other sites

Hi PF22,

My name is Rachel and I work in the marketing team for Whale.

Please contact our Customer Support Team who will do all they can to assist you with your query. Contact details below. 

Tel: 02891 270531 (weekdays) or 0845 217 2933 (weekends)

Email: info@whalepumps.com

Alternatively send me the best number to get you on in a private message and I will get one of our team to give you a call back. 

Best wishes

Rachel

  • Like 1

Share this post


Link to post
Share on other sites
On 01/04/2019 at 22:36, PF22 said:

Hi

 

Had our caravan for about 9 months and it appears second water pump has gone. 

 

Is this normal, or should they last for a lot longer? 

 

Thanks. 

We've had our Bailey Rimini 2013 for 2.5 years and we` are on our second pump!:unsure:

WHALE FP0814 WATERMASTER 

The 1st one packed up just as we arrived on site on the Isle of Wight, great fun!

We've just been away for a tester before visiting the island again later this month and it took an age for the system to pressurise, even though I had tried the system at home prior to our last trip, so not too impressed really.

 

It seemed to be down to an air lock somewhere in the system. It worked ok once I had got the pump to draw the water into the system, but now very nervous every time I hook up the water:(

The pump just didn't appear to be running properly, which, I presume, was down to the airlock?

The pump is less than 12 months old and we've not used the van much since it was replaced.

Share this post


Link to post
Share on other sites
19 hours ago, WhaleSupport said:

Hi PF22,

My name is Rachel and I work in the marketing team for Whale.

Please contact our Customer Support Team who will do all they can to assist you with your query.

Best wishes

Rachel

:Thankyou:

Share this post


Link to post
Share on other sites

Have you guys checked the pump fuse?

Share this post


Link to post
Share on other sites

I had problems with a Whale pump, which I fixed read all about it here

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  



×
×
  • Create New...