Jump to content
THECDs

New Buccaneer Aruba Incoming tomorrow February 1st!

Recommended Posts

Well it really does feel like Christmas Eve right now. I have forgotten how this feel to be honest but we are all super excited.  

 

The car is packed with essentials and bedding etc. The local CMC site is booked near the dealer and we are collecting our Buccaneer Aruba tomorrow for our very first caravan and night away in it, all in one go. Wow.  

 

I've had a towing experience at the Manchester show, but that is ALL!!! Shock. I'm sure I'll be fine (hilarious). Tow bar is fitted ready and we have been assured that we are going to have a dedicated afternoon of instruction and handover from our dealer.  

 

We have decided on the Bradcot Modul Air awning and we pick that up tomorrow with the Aruba.  

 

I'm thinking that If we do all of this as our first outing and it snows then we will have had EVERYTHING thrown at us and we will learn VERY quickly indeed.  

 

Update tomorrow and some pictures too!!

 

Mike

Share this post


Link to post
Share on other sites

Excellent, bet you don't sleep much tonight:)

Where is your local CMC site? We will be at Knaresborough on Monday in ours.

Share this post


Link to post
Share on other sites

They are Yorkshire residents too gmc15,

 

geoff

Share this post


Link to post
Share on other sites

Yeah. We are in West Yorkshire and buying from a North Yorkshire dealer. Staying two nights near Richmond. Can’t wait.  

Share this post


Link to post
Share on other sites

Hope everything goes well. Take a small fan heater as a back up until you get the heating going.

Share this post


Link to post
Share on other sites
13 hours ago, Paul1957 said:

Hope everything goes well. Take a small fan heater as a back up until you get the heating going.

No need in the Buccaneer as it has underfloor heating so warms up quite quickly!

Share this post


Link to post
Share on other sites

Not pleasant up here today, drive safely.

Share this post


Link to post
Share on other sites

Make sure the waste drain has a clear path to empty.   Our connection to the waste barrel was slightly raised last year when out when the beast from the east struck the water froze solid. Had fun clearing it, not.

Share this post


Link to post
Share on other sites

Might seem very obvious but use both gas and electric boiler functions when you start up as electric only will be slow.

Good luck. Stay calm. Think, re-think then act.   It's dropping out of logical sequence that causes problems.

Enjoy your new van.

GB.

Share this post


Link to post
Share on other sites

When you are finished with your outing, make sure that the water system is fully drained and leave all taps open.   I strongly suggest that the water filter is removed and don't bother with fitting it again.   We had ours removed before we even took delivery of our Buccaneer.

Share this post


Link to post
Share on other sites
23 hours ago, Durbanite said:

No need in the Buccaneer as it has underfloor heating so warms up quite quickly!

 

Taking a fan heater on the first trip was IMO good insurance advice as unless the Alde had a proper PDI then an early life airlock leading to no warming up has been  far from unknown.

Great system set up correctly and I hope the whole experience is now going well.

  • Like 2

Share this post


Link to post
Share on other sites
14 hours ago, Durbanite said:

When you are finished with your outing, make sure that the water system is fully drained and leave all taps open.   I strongly suggest that the water filter is removed and don't bother with fitting it again.   We had ours removed before we even took delivery of our Buccaneer.

Is the water filter a new addition? Ours is a 2017. Sorry for hijacking the thread.

Share this post


Link to post
Share on other sites

There was a water filter in my 2015 in behind the sink unit drawers.

 

You need to remove the drawers to get access to it.

 

Ian

  • Thanks 1

Share this post


Link to post
Share on other sites
10 hours ago, CraigP2005 said:

Is the water filter a new addition? Ours is a 2017. Sorry for hijacking the thread.

Yours definitely has the water filter which is fitted behind the drawers.   Right pain to get to if the unit splits or needs replacing.   Easier to get the dealer to remove and to leave out.

  • Thanks 1

Share this post


Link to post
Share on other sites
18 minutes ago, Durbanite said:

Yours definitely has the water filter which is fitted behind the drawers.   Right pain to get to if the unit splits or needs replacing.   Easier to get the dealer to remove and to leave out.

Do you recommend removing the filter due to the possibility of it freezing and cracking or are there other reasons? Our 2017 Schooner must have one fitted and with this very cold weather I wonder if I should remove it.

Share this post


Link to post
Share on other sites

Our 2011 Elddis had an in-line Whale filter in the cold water pipe to the kitchen sink, hidden under the front seats. It was easy to replace with another bit of pipe and fittings and never used again.  https://www. ebay. co. uk/p/Whale-Aquasource-Caravan-Motorhome-Inline-Water-Filter-12mm-WF1230/1005407985?iid=143083069770&chn=ps

 

There is another recent topic on filters and it was mentioned they can fill up with green algae, so if not replaced frequently they might be a health hazard. I initially removed ours as part of draining down but when I saw the new cost never put one back.

 

Edited by Paul1957

Share this post


Link to post
Share on other sites

We are alive!!! Just. Ha. Loving it!!!!!!

 

What a drama though. The snow came thick and fast in Richmond. Full up date when we get back.  

 

All is well with our Aruba.  

 

Mike.  

Share this post


Link to post
Share on other sites

IMG_2197.jpg.e1bb41e473961e2aa31aca3e82aa9e6f.jpgIMG_1582.jpg.439a9ff1e49afc3956818643b67cb8c4.jpgIMG_2182.jpg.6cb4fb28e2a01a4c931efc377f38a8e4.jpgIMG_0347.JPG.7b17958079ad1a439924b72c08aaddcf.JPGIMG_2179.jpg.f0ffb9eb5add9a5cf792eb34478a40e4.jpgIMG_2170.jpg.f2df5defa7cc893573adaa49ae011f87.jpg

Share this post


Link to post
Share on other sites

Nice looking outfit:)

Looking forward to your report.

Share this post


Link to post
Share on other sites
50 minutes ago, gmc15 said:

Nice looking outfit:)

Looking forward to your report.

 

Thanks GMC15. I'll get a full write up on here soon.  

Share this post


Link to post
Share on other sites
23 hours ago, gmc15 said:

Do you recommend removing the filter due to the possibility of it freezing and cracking or are there other reasons? Our 2017 Schooner must have one fitted and with this very cold weather I wonder if I should remove it.

The fitting is a push pull type so easy to remove the filter once you can get to it as you have to remove all the drawers if a Cruiser and one or two other Buccaneer models.   With our 2016 Cruiser after a few weeks use the pipe came off the filter and flooded the caravan.   We no longer own that caravan.

Share this post


Link to post
Share on other sites

If you check on the filter it should have, as with all the other joints,little red clips to stop the release buttons coming back on there self. our pipe came off at the inboard water tank and also flooded the floor under the bed. When i approached the dealer they said they where supposed to be on all joints and did them all the following week. or ask dealer too send you them. they only pushon to the joint and would save a trip to dealer.

Share this post


Link to post
Share on other sites

I was having trouble running the water from the internal tank without the water thing plugged in on the outside. What was I doing wrong?  

 

If if you don’t plug in the aqua roll but the internal tank is full is that not workable? 

 

Seems strange.  

Share this post


Link to post
Share on other sites
2 hours ago, THECDs said:

I was having trouble running the water from the internal tank without the water thing plugged in on the outside. What was I doing wrong?  

 

If if you don’t plug in the aqua roll but the internal tank is full is that not workable? 

 

Seems strange.  

Did you flick the pump switch to internal?

Share this post


Link to post
Share on other sites

I think so. We were trying all of the various positions. Might need to test again. I’m sure it’s user error.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×