Jump to content
Sign in to follow this  
CaravanDave78

ESM 2 battery charger problems

Recommended Posts

Hi all, a newbie to the site and in need of urgent advice. I have a 2003 Ace Award Transtar (with Jubilee spec interior). I have brought it back from storage to find that my plug-in-systems ltd ESM2 is no longer charging my battery when plugged into mains (the battery charges whilst on tow). I have contacted Newport Caravans but they are unable to supply a new unit and recommended contacting the manufacturer of van. I need to be able to get a new u it that I can plug in without having to replace cabling as I have got a clue there! I’m willing to pay an engineer to do it for me, but cannot get hold of anyone who isn’t fully booked up. Can anyone give any advice, please?? Thanks!

Share this post


Link to post
Share on other sites

The very best person to talk to is Paul at Apuljack Engineering.
He will go through some things with you on the phone and if needed he can repair your current unit to better than new, but at a lesser cost than buying new.

www. apuljackengineering. co. uk/
 

Share this post


Link to post
Share on other sites

Hi

Contact Steve

Plug In Systems Spares and Advice - Spares and Advice

www. expluginsteve. co. uk/

Welcome to my web page for advice and repairs to your caravan/motorhome Plug- in-Systems power management system, battery charger and alarm.

Dave

 

Share this post


Link to post
Share on other sites

:welcome:To The Forum,

If you are looking to be going away this Easter then what you could do is connect a car battery charger to your leisure battery and just switch it on as and when you see the voltage dropping. I have done this in the past when my charger packed up in France and got me through a 3 week holiday. Hope you get sorted soon.

Dave

Share this post


Link to post
Share on other sites

Sometimes chargers have a kettle type plug in the back which comes loose, its worth checking before parting with any money ;)

Share this post


Link to post
Share on other sites

Hi my esm unit does nothing on my 2001  Swift charisma, I switched on my fitted fire and it blew all the house fuses ,my esm is dead , is there an independent fuse in the back of it or do you think the short out. Nuked it . 

Thanks hope you have some idea can’t find any 240v fuses in van power is coming in from my 240v hook up

Share this post


Link to post
Share on other sites

Welcome

The incoming 240V mains is protected, normally, by MCBs which are circuit breakers as in your house, whereas the 12V supply is protected by fuses.

You appear to gave a short if the incoming mains is being tripped outside of your van.

Share this post


Link to post
Share on other sites

Thanks , no power at all from ESM but power going in on the rear kettle plug , 240v is being fed , wonder if there’s an internal fuse behind all those rivets , checked all 240v fuses I can find no fridge , wall lights , heater ,etc 

thank you

Share this post


Link to post
Share on other sites

Linked topic

 

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...