Jump to content

Toyota Rav4 / Sterling Elite 480 Indicator Problems


Martin9531
 Share

Recommended Posts

Hi, new tow bar on car fitted with 13 pin socket by Toyota dealer, new Sterling caravan . Whilst stationary all road lights on caravan work as they should, when moving and road lights used singly they work as they should. However when brake and indicators applied together, indicators flash rapidly indicating a problem.

Car has spent 2 days with Toyota having electrics checked and various new bits fitted. We have just returned from caravan dealer having a load box fitted to compensate for LED's. Problem still happens!

Anyone had similar or offer any advice.

Thanks

Link to comment
Share on other sites

Having a towing socket fitted by the main dealer could mean it is just taken to the local towbar fitter to fit so I would not rule out a fault still . If the caravan has a new load box fitted to compensate for the LEDs it should be fine if it was wired correct .

 

 

I would try different caravans or trailer board and different cars if you can to eliminate where the fault is .

 

 

 

Dave

Jeep Commander 3. 0 V6 CRD

Isuzu D- Max Utah Auto

Elddis Crusader Storm 2000 Kgs, Unipart Royal Atlas Mover .

 

Link to comment
Share on other sites

I'd try a trailer board or another caravan (prefereably one without LED lights) to see if it works OK.

 

Unfortunately most car electrics aren't at all happy with LED lights on the trailers, that's the reason that Bailey reverted to bulb road lighting on the Unicorn range. LEdD were causing all sorts of problems on various marques of car which had been fitted with dedicated electronics and specific bodging boxes had to be provided depending on the car.

 

Those with by-pass electrics were generally fine as the car was unaware that a van had been connected

2018 S-Max Titanium 2. 0 Tdci (177. 54bhp,180ps,132kw) Powershift + 2015 Unicorn III Cadz, Ventura Marlin porch awning

Link to comment
Share on other sites

I was told I needed one of these magic boxes for my BMW when we got our new Swift (all LED) last year. Dealer fitted it and when I went to pick it up the lights were a real mess (Sargent Electronics confirmed I needed the box fitting to the van).

 

Anyway, the box was removed and the car/van combination works perfectly without it, all vehicle sensors (including stability system) work, and the car is fitted with a genuine BMW harness.

 

Not convinced the dealers or Sargent know what needs fitting (if anything), they seem to do more harm than good and should really try the combination before they start messing about if they aren`t 100% certain.

Link to comment
Share on other sites

You don't actually say what effects you get when you simultaneously brake and indicate, and does it happen with indicators on both sides or just one?

 

What happens if you brake whilst hazard flashers are running?

 

Are there any effects when the sidelights are on?

2018 Passat B8 Estate 150GT TDi150 towing a 2018 Bailey Unicorn S4 Seville

Link to comment
Share on other sites

Sounds like an earthing fault some where.

2011 Land Rover Freelander 2, Lago grey 2013 Freelander Dynamic Black, followed by a 2013 Elddis 574 Magnum GT white

Link to comment
Share on other sites

Although you don't state what actually happens Martin, the last time I had a similar problem it turned out to be poor earthing in the boot of the car. My mate also had something like this which was down to a bad earth in a 7-pin plug. So it might be worth checking bolt and screw tightness before going any further.

 

John

 

Oh, and by the way :welcome: to the forum.

Link to comment
Share on other sites

Thanks for all the replies. Initially the caravan didn't have the load box fitted and I didn't notice any problems with the indicators, that was bringing the van home from the dealers. A few days later we travelled to a very local site to try everything out, this is when the problem first arose. The indicators flash twice as quick as they should, indicating a fault. Fortunately the Toyota garage that fitted the tow are was close by so I called in to ask, they initially suspected a faulty earth and so cleaned and tightened all earth connections. This didn't improve the fault, so I booked the car in for further investigation. They replaced all of the electric side of the tow bar and even took it to a local tow bar company and had it checked out there. All came back OK.

Back to caravan dealer, they checked towbar electrics with trailer board, again OK, I even went for a drive with the trailer board in the boot to try and recreate the problem, everything fine. Yet put the caravan on problem reoccurs. Had the load box fitted today, travelled about 5 miles no problem then it happened again. I'm beginning to wonder if the manufacturer has put a screw through the wiring harness or something totally random like that as it's a bit frustrating on a new van.

Link to comment
Share on other sites

I have recently taken delivery of a swift, and didn't expect any problems as I have by pass electrics.

However I insisted on trying all the lighting functions only to find the indicators didn't beep anymore!

So a VLM box was fitted, and sorted the problem straight away, they simply interface with the existing 12 volt road light panel, so are plug and play.

 

There are also different types of VLM, so you need to know which one is required, some have had to be modified by Sargent so yours might be one of those.

Edited by xtrailman
Link to comment
Share on other sites

As said could be an earthing problem . It could be a loose connection and the a intermittent connection and I have had it were a earth connection failed but the earth was making intermittent through the towball and hitch .

 

 

Earth faults can show as a number of different problems .

 

 

Dave

Jeep Commander 3. 0 V6 CRD

Isuzu D- Max Utah Auto

Elddis Crusader Storm 2000 Kgs, Unipart Royal Atlas Mover .

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...