Jump to content

Mdm83

Approved Member
  • Content Count

    7
  • Joined

  • Last visited

About Mdm83

  • Rank
    New to the board

Profile Information

  • Gender
    Male
  • Location
    Aberdeenshire
  • Towcar
    VW Amarok
  • Caravan
    Sterling Europa 495

Recent Profile Visitors

32 profile views
  1. My battery is a Duracell 115ah- which apparently is a banner battery. My charger is a maypole mp7428 8A smart charger when connected to charge the charger stated 5% charged its now at 95% charged @14.6v / 0.8A do these figures seem ok? I know discharging below 50% isn’t good but I’m hoping with it being a brand new battery it will recover?
  2. They are both thin wires next to the black fuse box- under the left front seat- the main A.C. feed is under the from right seat Trying to google what the battery charger looks....... daft question but is the charger separate to the mains isolater- ne143_rm?
  3. Thanks yes its a nordelettronica model NE143_RM Is it the whole unit that needs replaced ? If it’s just the charger where is it/what does it look like? hopefully a diy job?
  4. Maypole mp7428 8amp. its at home- I assumed a brand new battery would last a weekend away. the charger was recommended on a caravan advice site At least I’ve gotten a good couple of months to get it fixed over winter
  5. I have a maypole smart charger that we use. Although this time the new battery arrived the night before we left so I just put it straight in the caravan as I assumed it would be fully charged- which is stated on the order letter it came with. The battery is a ncc class b battery so I assumed it would be ok? Forgot to mention that the motor mover gets used when setting up. Ive read somewhere that the transformers on these caravans can be troublesome?
  6. Hi I’m new to the site we have recently bought a 2008 sterling europa 495 and this is our second time using it with the same resulting issues. It’s our second caravan and have been caravaning for 3 years. The same issue has happened- after 2/3 days of use the lights go dim, the cooker ignition stops, water pump stops, fridge light goes out & central heating fans stop( but heater still works) the display unit on the mains isolater goes blank but the 3 switches- heater/water heater/ battery charger still light up. Although this morning it now reads 7.8 instead of the 12? We always have the battery charger switched on. Its as though half the caravan is running in electric hook up and the other half is relying on the battery which is being drained very quickly? we leave home with a fully charged brand new battery- Duracell/banner 115ah On our first trip this happened I suspected the battery so bought the new duracell battery for £130 but 3 days into our stay the same issues happened. When in use the caravan is hooked up to electrics. Ive checked the black fuse box and all fuses are ok. Next to the fuse box are 2 loose/free wires with nowhere to go? Id really appreciate any advice on this as it’s driving us nuts!!
×
×
  • Create New...