Jump to content


Photo

Truma Heater


  • Please log in to reply
4 replies to this topic

#1 A1redale

A1redale

    One Star

  • Approved Member
  • Pip
  • 14 posts
  • Location:York

Posted 28 January 2008 - 01:34 PM

Hi to everyone,

Hoping I can prevail upon the collective wisdom on the forum.

Last time we used the van the heater ceased to heat on the lelectricity option but continued to work if used on gas.

Checked the spur which is housed in the wardrobe of 2002 Lunar Sloar Eclipse and the light was out.

Bought some standard domestic fuses as these looked the same size as the fuse cover on the spur.

On removing the fuse from the spur discovered it was 10 amp - domestic pack only had 3, 5, and 13 amp fuses.

Erred on the side of caution and fitted a 5 amp fuse.

Connected the van to mains at home and the Truma worked on electricity inituially and then went off.

Checked the spur this weekend and the fuse has melted the holder within the spur.

This raises a number of questions:

1. Where can I get a replacement spur?

2. Is the fault likely to be the spur or is there anything within the heater that may have caused the short?

3. I don't intend to carry out the repair myself - should I leave it to the guy who normally services the van or contact Truma?

Sorry to ask so many questions but this has left me perplexed as I would have expected the fuse to blow rather tan melt the surround?

Thanks in anticipation

Steve

#2 Arc Systems

Arc Systems

    Five Star

  • Trade
  • PipPipPipPipPip
  • 2,402 posts
  • Gender:Male
  • Location:Nottinghamshire

Posted 29 January 2008 - 09:48 AM

Two possible facts are,
1, the original 10A fuse blew but did not melt the fuse holder?
2, a replacement 5A fuse did not blow but managed to melt the fuse holder?

First I can say your Truma fuse holder is not the first to melt, second the max current drawn on the 2000w setting should be no more than 9A and the fuse holder must be safely rated at 13A and probably 16A or more

So, if the 5A did not blow, the setting was not more than 1000W, (under 4.5A), and the fuse was loose in the holder which creates electrical resistance.

My guess would be, the 10A fuse was actually ok but loose enough to completely break the connection, the replacement 5A made a connection but so poorly the heat caused by the high resistance melted the holder?

Replacement switch spurs you should be able to get through any caravan dealer

#3 A1redale

A1redale

    One Star

  • Approved Member
  • Pip
  • 14 posts
  • Location:York

Posted 29 January 2008 - 10:29 AM

Two possible facts are,
1, the original 10A fuse blew but did not melt the fuse holder?
2, a replacement 5A fuse did not blow but managed to melt the fuse holder?

First I can say your Truma fuse holder is not the first to melt, second the max current drawn on the 2000w setting should be no more than 9A and the fuse holder must be safely rated at 13A and probably 16A or more

So, if the 5A did not blow, the setting was not more than 1000W, (under 4.5A), and the fuse was loose in the holder which creates electrical resistance.

My guess would be, the 10A fuse was actually ok but loose enough to completely break the connection, the replacement 5A made a connection but so poorly the heat caused by the high resistance melted the holder?

Replacement switch spurs you should be able to get through any caravan dealer


Gary - as ever mant thanks for the reply I'll obtain a replacement spur and try that.

#4 A1redale

A1redale

    One Star

  • Approved Member
  • Pip
  • 14 posts
  • Location:York

Posted 16 February 2008 - 09:45 PM

Update on faulty heater.

I replaced the fused spur/switch and the heater is now working.

Again many thanks go to Gary (Arc Systems) for his advice.

Which has saved me considerable time and expense.

Steve

#5 Guest_Surfer_*

Guest_Surfer_*
  • Guest

Posted 17 February 2008 - 09:36 AM

Two possible facts are,
1, the original 10A fuse blew but did not melt the fuse holder?
2, a replacement 5A fuse did not blow but managed to melt the fuse holder?

First I can say your Truma fuse holder is not the first to melt, second the max current drawn on the 2000w setting should be no more than 9A and the fuse holder must be safely rated at 13A and probably 16A or more

So, if the 5A did not blow, the setting was not more than 1000W, (under 4.5A), and the fuse was loose in the holder which creates electrical resistance.

My guess would be, the 10A fuse was actually ok but loose enough to completely break the connection, the replacement 5A made a connection but so poorly the heat caused by the high resistance melted the holder?

Replacement switch spurs you should be able to get through any caravan dealer

I would imagine that dirty contacts would also cause a similar problem.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users